use strict;
my $str = '{&var} --> Variable stored in a dictionary --> dict("var")
{$prop} --> Property of a class cls.prop read by CallByName and PropGet
{#const} --> Some constant values by name from a function
Value of foo is \'{&var:DD.MM.YYYY}\' and bar is \'{$prop}\'
Value of foo is \'{&var:DD.{MM}.YYYY}\' and bar is \'{$prop}\'
Value of foo is \'{&var:DD.\\{MM\\}.YYYY}\' and bar is \'{$prop}\'
This should not match \'\\{&var:DD.\\{MM\\}.YYYY\\}\' but this one \'{&var:DD.\\{MM\\}.YYYY}\'
Start {$var01}{$var02} End ';
my $regex = qr/((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?(?=})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}