# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:^|[^\\\n])(?:\\{2})*)\{([#$&])([\w.]+)(?::([^}\\]*(?:\\.[^}\\]*)*))?(?=})"
test_str = ("{&var} --> Variable stored in a dictionary --> dict(\"var\")\n"
"{$prop} --> Property of a class cls.prop read by CallByName and PropGet\n"
"{#const} --> Some constant values by name from a function\n"
"Value of foo is '{&var:DD.MM.YYYY}' and bar is '{$prop}'\n"
"Value of foo is '{&var:DD.{MM}.YYYY}' and bar is '{$prop}'\n"
"Value of foo is '{&var:DD.\\{MM\\}.YYYY}' and bar is '{$prop}'\n"
"This should not match '\\{&var:DD.\\{MM\\}.YYYY\\}' but this one '{&var:DD.\\{MM\\}.YYYY}'\n"
"Start {$var01}{$var02} End ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.