package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^:\s+(\S.*?)\s*Network type`)
var str = `: Dog 172 Network type : Infrastructure Authentication : WPA2-Personal Encryption : CCMP BSSID 1 : FF:FF:FF:FF:FF:FF Signal : 91% Radio type : 802.11n Channel : 1 Basic rates (Mbps) : 1 2 5.5 11 Other rates (Mbps) : 6 9 12 18 24 36 48 54`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}