$re = '/^:\s+(\S.*?)\s*Network type/m';
$str = ': Dog 172 Network type : Infrastructure Authentication : WPA2-Personal Encryption : CCMP BSSID 1 : FF:FF:FF:FF:FF:FF Signal : 91% Radio type : 802.11n Channel : 1 Basic rates (Mbps) : 1 2 5.5 11 Other rates (Mbps) : 6 9 12 18 24 36 48 54';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);