const regex = /(.)(?=#)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)(?=#)', 'i')
const str = `a#bc# -#`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);