use strict;
my $str = 'a#bc# -#';
my $regex = qr/(.)(?=#)/ip;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";