re = /\b(x*)\1*+(x+) % \1\b = \2\b/m
str = 'xxx % xx = x
xxxxxx % xxxx = xx
xxxxxxx % xx = x
should not match:
xxxxx % xxxxx = xxxxx
xxxxxxxxxxxxxx % xxx = xxxxx
xxxxxxxxxxxx % xx = x
xxxxx % xxx = xxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end