import Foundation
let pattern = #"\b(x*)\1*+(x+) % \1\b = \2\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
xxx % xx = x
xxxxxx % xxxx = xx
xxxxxxx % xx = x
should not match:
xxxxx % xxxxx = xxxxx
xxxxxxxxxxxxxx % xxx = xxxxx
xxxxxxxxxxxx % xx = x
xxxxx % xxx = xxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)