$re = '/^(?=.*?a)(?=.*?b)(?=.*?c)[abc]{3}$/m';
$str = 'abc
acb
bac
bca
cab
cba
aab
bbc
aba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);