re = /^(?=.*?a)(?=.*?b)(?=.*?c)[abc]{3}$/m
str = 'abc
acb
bac
bca
cab
cba
aab
bbc
aba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end