package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(192.168.$|10.$)`)
var str = `longstring192#168#`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}