const regex = /(192.168.$|10.$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(192.168.$|10.$)', '')
const str = `longstring192#168#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}