use strict;
my $str = '[2018.07.10 00:30:03:640][TraceID: 8HRWSI105YVO91]->StartExecuteTask\\35
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->RequestInfo\\27
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->RequestExecuteEnd\\16
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->OutgoingData\\26651
[2018.07.10 00:31:16:773][TraceID: G8EM5LANBPC32H]->CheckUserInfo\\141';
my $regex = qr`(?:\[|->)(.*?)[\\\]]`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}