re = /(?:\[|->)(.*?)[\\\]]/m
str = '[2018.07.10 00:30:03:640][TraceID: 8HRWSI105YVO91]->StartExecuteTask\\35
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->RequestInfo\\27
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->RequestExecuteEnd\\16
[2018.07.10 00:30:18:585][TraceID: 8707HFH7NR6307]->OutgoingData\\26651
[2018.07.10 00:31:16:773][TraceID: G8EM5LANBPC32H]->CheckUserInfo\\141'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end