package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)esdfdsdg`)
var str = `[MediaClient.19516, 2022-09-06T08:55:47.011; Info]: (pjproject_interface_impl.cc:171): pjsua_core.c:459 .RX 2702 bytes Response msg 200/INVITE/cseq=7943 (rdata000001EF7B4F91D0) from TLS 203.252.54.20:443: to 192.259.19.37:59160
SIP/2.0 200 OK
Via: SIP/2.0/TLS 192.259.19.37:59160;rport=59160;received=64.37.175.80;branch=z9hG4bKPj5eaadcef35a3486e9414d26c3b329ba7
Call-ID: 219a7090d9464e5988618fa5d9e022dc
From: "John dale" <sip:fiber@service.com>;tag=3a931b11390244bc990d45e82b8345ed
To: "service" <sips:c016130e-fa4e-454a-b249-4a6f8d6cf276@sip-203-252-54-20.bjn.vc>;tag=MTAuMTA4LjEyLjE4OjQ1ODExOjI-
CSeq: 7943 INVITE
Contact: "Service" <sip:c016130e-fa4e-454a-b249-4a6f8d6cf276@sip-203-252-54-20.cji.vc:443;transport=tls>
Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, INFO, OPTIONS
Supported: 100rel
Content-Type: application/sdp
Content-Length: 2027
v=0
o=BlueJeans 0 3871442120 IN IP4 203.252.54.20
s=-
c=IN IP4 203.252.54.20
t=0 0
a=x-bwmgr:delay
a=extmap:1 http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time
m=audio 42613 RTP/SAVP 121 96
a=crypto:1 AEAD_AES_256_GCM
a=rtcp:42613
a=rtpmap:121 DVC-2/8000
a=rtpmap:96 telephone-event/8000
a=fmtp:96 0-15
a=sendrecv
a=ice-ufrag:b510
a=ice-pwd:2224b63a+7b01+4929+9ba6+
a=candidate:H67ff3614 1 UDP 2130706431 103.255.54.20 42613 typ host
a=rtcp-mux
a=remote-candidates:1 203.252.54.20 26047 2 203.252.54.20 26047
m=video 42614 RTP/SAVP 102 122 116 125
b=TIAS:4096000
a=crypto:1 AEAD_AES_256_GCM
--end--msg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}