import re
regex = re.compile(r"esdfdsdg", flags=re.MULTILINE)
test_str = ("[MediaClient.19516, 2022-09-06T08:55:47.011; Info]: (pjproject_interface_impl.cc:171): pjsua_core.c:459 .RX 2702 bytes Response msg 200/INVITE/cseq=7943 (rdata000001EF7B4F91D0) from TLS 203.252.54.20:443: to 192.259.19.37:59160\n"
"SIP/2.0 200 OK\n"
"Via: SIP/2.0/TLS 192.259.19.37:59160;rport=59160;received=64.37.175.80;branch=z9hG4bKPj5eaadcef35a3486e9414d26c3b329ba7\n"
"Call-ID: 219a7090d9464e5988618fa5d9e022dc\n"
"From: \"John dale\" <sip:fiber@service.com>;tag=3a931b11390244bc990d45e82b8345ed\n"
"To: \"service\" <sips:c016130e-fa4e-454a-b249-4a6f8d6cf276@sip-203-252-54-20.bjn.vc>;tag=MTAuMTA4LjEyLjE4OjQ1ODExOjI-\n"
"CSeq: 7943 INVITE\n"
"Contact: \"Service\" <sip:c016130e-fa4e-454a-b249-4a6f8d6cf276@sip-203-252-54-20.cji.vc:443;transport=tls>\n"
"Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, INFO, OPTIONS\n"
"Supported: 100rel\n"
"Content-Type: application/sdp\n"
"Content-Length: 2027\n\n"
"v=0\n"
"o=BlueJeans 0 3871442120 IN IP4 203.252.54.20\n"
"s=-\n"
"c=IN IP4 203.252.54.20\n"
"t=0 0\n"
"a=x-bwmgr:delay\n"
"a=extmap:1 http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time\n"
"m=audio 42613 RTP/SAVP 121 96\n"
"a=crypto:1 AEAD_AES_256_GCM \n"
"a=rtcp:42613\n"
"a=rtpmap:121 DVC-2/8000\n"
"a=rtpmap:96 telephone-event/8000\n"
"a=fmtp:96 0-15\n"
"a=sendrecv\n"
"a=ice-ufrag:b510\n"
"a=ice-pwd:2224b63a+7b01+4929+9ba6+\n"
"a=candidate:H67ff3614 1 UDP 2130706431 103.255.54.20 42613 typ host\n"
"a=rtcp-mux\n"
"a=remote-candidates:1 203.252.54.20 26047 2 203.252.54.20 26047\n"
"m=video 42614 RTP/SAVP 102 122 116 125\n"
"b=TIAS:4096000\n"
"a=crypto:1 AEAD_AES_256_GCM \n\n"
"--end--msg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")