re = /(?=.*[0-9].*[0-9].*[0-9])(?=.*[A-Z].*[A-Z].*[A-Z])[A-Za-z0-9]{8,30}/m
str = 'aaaaaSaaSasAd212D
gfgfdgdSSSdsad3f3
dfsdfsfdf3fsdfsfF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end