package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(foo|qux quux)\b`)
var str = `foo bar foo5 bar foo-bar foo qux quux\n foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}