$re = '/\b(foo|qux quux)\b/m';
$str = 'foo bar foo5 bar foo-bar foo qux quux\\n foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);