package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) (\d{7})
`)
var str = `1° OA: 3824105_13884333_13890301_13890446_13894550_1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}