$re = '/ (\d{7})
/m';
$str = '1° OA: 3824105_13884333_13890301_13890446_13894550_1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);