package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*NewTree\w*|([a-zA-Z]+)`)
var str = `NewTree
BoostKite
SetTree
foobar
ComeNewTree`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}