using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""http.?:.*(?:youtube.com\/|youtu.be\/)(?:watch\?v=|watch\?t=.*v=|embed\/|)(\w{11})<\/a>";
string input = @"the following URL will be found in a <A>:<br>
<em>
<a href=""https://www.youtube.com/watch?t=61&v=JozAmXo2bDE"" rel=""nofollow"">https://www.youtube.com/watch?t=61&v=JozAmXo2bDE</a>
<br>
<div class=""content"" component=""post/content"" itemprop=""text"">
<p><a href=""/uploads/files/1438503488609-chingles-tutti.mp3"">Chingles - Tutti.mp3</a>
</p>
<a href=""https://soundcloud.com/eyesandfire/eyesandfire-klangwelten-iii"" rel=""nofollow"">https://soundcloud.com/eyesandfire/eyesandfire-klangwelten-iii</a>
<p><a href=""https://soundcloud.com/upsolution2/der-grose-diktator-upsolution2-rmx"" rel=""nofollow"">https://soundcloud.com/upsolution2/der-grose-diktator-upsolution2-rmx</a></p>
<p><a href=""/uploads/files/1438503488608-chingles-tutti-frutti-television-commercial.ogg"">Chingles Tutti Frutti Television Commercial.ogg</a></p>
</div>
<p><a href=""/uploads/files/1438502408123-chingles-tutti.mp3"">Chingles - Tutti.mp3</a>
<a href=""/uploads/files/1438502408122-chingles-tutti-frutti-television-commercial.ogg"">Chingles Tutti Frutti Television Commercial.ogg</a>
<a href=""/uploads/files/1438502408122-chingles-tutti-frutti-television-commercial.wma"">Chingles Tutti Frutti Television Commercial.wma</a>
<a href=""/uploads/files/1438502408121-chingles-tutti-frutti-television-commercial.m4a"">Chingles Tutti Frutti Television Commercial.m4a</a>
<a href=""/uploads/files/1438502408121-chingles-tutti-frutti-television-commercial.aac"">Chingles Tutti Frutti Television Commercial.aac</a>
<a href=""/uploads/files/1438502408120-chingles-tutti-frutti-television-commercial.flac"">Chingles Tutti Frutti Television Commercial.flac</a></p>
<a href=""https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap"" rel=""nofollow"">https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap</a>
<a href=""https://www.youtube.com/watch?v=VH2QAMMSL40"" rel=""nofollow"">https://www.youtube.com/watch?v=VH2QAMMSL40</a>
<br>
<a href=""http://www.youtube.com/embed/NLqAF9hrVbY"" rel=""nofollow"">http://www.youtube.com/embed/NLqAF9hrVbY</a>
<br>
<a href=""http://youtu.be/NLqAF9hrVbY"" rel=""nofollow"">http://youtu.be/NLqAF9hrVbY</a>
</em>
<br>
<a href=""http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM"" rel=""nofollow"">http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM</a>
</p>
<a href=""/uploads/files/1438381231924-humanistische-friedenspartei.mp3"">Humanistische - Friedenspartei.mp3</a>
<p>nice... <a href=""/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav"">DRUMLOOP053_AMBNT_160_X_SC5.wav</a></p>
<a href=""/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav"">DRUMLOOP053_AMBNT_160_X_SC5.wav</a>
<p>infos:<br>
<a href=""https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js"" rel=""nofollow"">https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js</a>
</p>
<p><a href=""https://github.com/ogerly/nodebb-plugin-youtube-lite"" rel=""nofollow"">https://github.com/ogerly/nodebb-plugin-youtube-lite</a></p>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}