import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"http.?:.*(?:youtube.com\\/|youtu.be\\/)(?:watch\\?v=|watch\\?t=.*v=|embed\\/|)(\\w{11})<\\/a>";
final String string = "the following URL will be found in a <A>:<br>\n"
+ "<em>\n"
+ "<a href=\"https://www.youtube.com/watch?t=61&v=JozAmXo2bDE\" rel=\"nofollow\">https://www.youtube.com/watch?t=61&v=JozAmXo2bDE</a>\n"
+ "<br>\n\n"
+ "<div class=\"content\" component=\"post/content\" itemprop=\"text\">\n"
+ " <p><a href=\"/uploads/files/1438503488609-chingles-tutti.mp3\">Chingles - Tutti.mp3</a>\n\n"
+ "</p>\n\n\n"
+ "<a href=\"https://soundcloud.com/eyesandfire/eyesandfire-klangwelten-iii\" rel=\"nofollow\">https://soundcloud.com/eyesandfire/eyesandfire-klangwelten-iii</a>\n\n"
+ "<p><a href=\"https://soundcloud.com/upsolution2/der-grose-diktator-upsolution2-rmx\" rel=\"nofollow\">https://soundcloud.com/upsolution2/der-grose-diktator-upsolution2-rmx</a></p>\n\n\n"
+ "<p><a href=\"/uploads/files/1438503488608-chingles-tutti-frutti-television-commercial.ogg\">Chingles Tutti Frutti Television Commercial.ogg</a></p>\n\n"
+ " \n"
+ "</div>\n\n\n"
+ "<p><a href=\"/uploads/files/1438502408123-chingles-tutti.mp3\">Chingles - Tutti.mp3</a> \n\n"
+ "<a href=\"/uploads/files/1438502408122-chingles-tutti-frutti-television-commercial.ogg\">Chingles Tutti Frutti Television Commercial.ogg</a> \n\n"
+ "<a href=\"/uploads/files/1438502408122-chingles-tutti-frutti-television-commercial.wma\">Chingles Tutti Frutti Television Commercial.wma</a> \n\n"
+ "<a href=\"/uploads/files/1438502408121-chingles-tutti-frutti-television-commercial.m4a\">Chingles Tutti Frutti Television Commercial.m4a</a> \n\n"
+ "<a href=\"/uploads/files/1438502408121-chingles-tutti-frutti-television-commercial.aac\">Chingles Tutti Frutti Television Commercial.aac</a> \n\n"
+ "<a href=\"/uploads/files/1438502408120-chingles-tutti-frutti-television-commercial.flac\">Chingles Tutti Frutti Television Commercial.flac</a></p>\n"
+ "<a href=\"https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap\" rel=\"nofollow\">https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap</a>\n\n\n"
+ "<a href=\"https://www.youtube.com/watch?v=VH2QAMMSL40\" rel=\"nofollow\">https://www.youtube.com/watch?v=VH2QAMMSL40</a>\n\n"
+ "<br>\n\n"
+ "<a href=\"http://www.youtube.com/embed/NLqAF9hrVbY\" rel=\"nofollow\">http://www.youtube.com/embed/NLqAF9hrVbY</a>\n\n"
+ "<br>\n\n"
+ "<a href=\"http://youtu.be/NLqAF9hrVbY\" rel=\"nofollow\">http://youtu.be/NLqAF9hrVbY</a>\n\n"
+ "</em>\n"
+ "<br>\n\n"
+ "<a href=\"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM\" rel=\"nofollow\">http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM</a>\n\n"
+ "</p>\n\n"
+ "<a href=\"/uploads/files/1438381231924-humanistische-friedenspartei.mp3\">Humanistische - Friedenspartei.mp3</a>\n\n"
+ "<p>nice... <a href=\"/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav\">DRUMLOOP053_AMBNT_160_X_SC5.wav</a></p>\n\n"
+ "<a href=\"/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav\">DRUMLOOP053_AMBNT_160_X_SC5.wav</a>\n\n"
+ "<p>infos:<br>\n\n"
+ "<a href=\"https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js\" rel=\"nofollow\">https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js</a>\n"
+ "</p>\n"
+ "<p><a href=\"https://github.com/ogerly/nodebb-plugin-youtube-lite\" rel=\"nofollow\">https://github.com/ogerly/nodebb-plugin-youtube-lite</a></p>\n\n"
+ " \n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}