const regex = /[\.\-_](?!\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\.\\-_](?!\\d)', 'g')
const str = `Welcome.to-RegEx_r.v2.0.03.by.gski.v2.0.03 danner.com!bla-la_122.232-13!`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);