import re
regex = re.compile(r"[\.\-_](?!\d)")
test_str = "Welcome.to-RegEx_r.v2.0.03.by.gski.v2.0.03 danner.com!bla-la_122.232-13!"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)