using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[۰۱۲۳۴۵۶۷۸۹]+$";
string input = @"123456
۰۱۲۳۴۵۶
۰۱۲۳۴۵٦";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}