const regex = /\bdelay\s*:\s*'(\d{4}-\d{1,2}-\d{1,2})\s*([^']*)'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bdelay\\s*:\\s*\'(\\d{4}-\\d{1,2}-\\d{1,2})\\s*([^\']*)\'', 'gm')
const str = `ticket:1 priority:5 delay:'2019-08-31 02:53:27.720422' delay:'2019-08-30 00:04:10.681242'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}