re = /\bdelay\s*:\s*'(\d{4}-\d{1,2}-\d{1,2})\s*([^']*)'/m
str = 'ticket:1 priority:5 delay:\'2019-08-31 02:53:27.720422\' delay:\'2019-08-30 00:04:10.681242\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end