import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[-:+ ]*|\\d\\d/\\d\\d/\\d\\d \\d\\d:\\d\\d:\\d\\d INFO acceleratorGenerator: )Filter\\s*(\\(.+\\)).*\\[pid: [-\\d]+, id: \\d+, (?:inner: \\S+, )?sid: [-\\d]+\\](?::\\s+\\{StructType\\(((?:\\s+StructField\\(\\S+, \\S+, [^)]+\\),?)+)\\)\\})?";
final String string = " +- Filter (((isnotnull(d_year#143) && (d_year#143 >= 1999)) && (d_year#143 <= 2001)) && isnotnull(d_date_sk#137)) [pid: 582, id: 583, sid: 67]\n"
+ " +- Filter(isnotnull(year_total # 875) && (year_total#875 > 0.0)) [pid: 26, id: 27, sid: 1]\n"
+ " +- Filter(((isnotnull(d_date_sk#137) && isnotnull(d_week_seq#141)) && (d_week_seq#141 = Subquery subquery877))) [pid: 159, id: 160, inner: false, sid: 16]: {StructType( StructField(d_date_sk, integer, false), StructField(d_week_seq, integer, false))}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}