# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[-:+ ]*|\d\d/\d\d/\d\d \d\d:\d\d:\d\d INFO acceleratorGenerator: )Filter\s*(\(.+\)).*\[pid: [-\d]+, id: \d+, (?:inner: \S+, )?sid: [-\d]+\](?::\s+\{StructType\(((?:\s+StructField\(\S+, \S+, [^)]+\),?)+)\)\})?"
test_str = (" +- Filter (((isnotnull(d_year#143) && (d_year#143 >= 1999)) && (d_year#143 <= 2001)) && isnotnull(d_date_sk#137)) [pid: 582, id: 583, sid: 67]\n"
" +- Filter(isnotnull(year_total # 875) && (year_total#875 > 0.0)) [pid: 26, id: 27, sid: 1]\n"
" +- Filter(((isnotnull(d_date_sk#137) && isnotnull(d_week_seq#141)) && (d_week_seq#141 = Subquery subquery877))) [pid: 159, id: 160, inner: false, sid: 16]: {StructType( StructField(d_date_sk, integer, false), StructField(d_week_seq, integer, false))}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.