package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("lat":|"lng":)"\s*(.+?)\s*"`)
var str = `"id":75549,"name":"Name","lat":"45.491834","lng":" -73.606953","address"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}