re = /("lat":|"lng":)"\s*(.+?)\s*"/m
str = '"id":75549,"name":"Name","lat":"45.491834","lng":" -73.606953","address"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end