# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d+)\|(?=.*?\b\1\b)//gm;t' <<< "0612|0613|061|0612|0612
0211|0612|021|0212|0211|0211
0111|0111
0511|0512|0511|0511|0521|0512|0511
"