const regex = /\b(\d+)\|(?=.*?\b\1\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\|(?=.*?\\b\\1\\b)', 'gm')
const str = `0612|0613|061|0612|0612
0211|0612|021|0212|0211|0211
0111|0111
0511|0512|0511|0511|0521|0512|0511
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);