#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)http.+(?:(?:v=)|(?:\/a\/u\/1\/)|(?:(?:v|embed|youtu\.be|shorts)\/))(?<videoId>.{11})[^<]*"
Local $sString = "<p>http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index</p><p>Para</p>" & @CRLF & _
"<p>http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o</p><p>Para</p>" & @CRLF & _
"<p>http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0</p><p>Para</p>" & @CRLF & _
"<p>http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s</p><p>Para</p>" & @CRLF & _
"<p>http://www.youtube.com/embed/0zM3nApSvMg?rel=0</p><p>Para</p>" & @CRLF & _
"<p>http://www.youtube.com/watch?v=0zM3nApSvMg</p><p>Para</p>" & @CRLF & _
"<p>http://youtu.be/0zM3nApSvMg</p><p>Para</p>" & @CRLF & _
"<p>https://youtube.com/shorts/0dPkkQeRwTI?feature=share</p><p>Para</p>" & @CRLF & _
"<p>https://youtube.com/shorts/0dPkkQeRwTI</p><p>Para</p>" & @CRLF & _
"<p>https://www.youtube.com/watch?v=0dPkkQeRwTI&ab_channel=RelaxedChan</p><p>Para</p>"
Local $sSubst = "<iframe width="100%" src="https://www.youtube.com/embed/$videoId" frameborder="0" allowfullscreen></iframe>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)