package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(::)?.*\(.*\)`)
var str = `static void OutClass::OurMethod(int a)
static void OurFunction(int b)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}