$re = '/\w+(::)?.*\(.*\)/m';
$str = 'static void OutClass::OurMethod(int a)
static void OurFunction(int b)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);