using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:is listening to|is watching|is playing|is editing) \[https?://osu.ppy.sh(/beatmapsets/(\d+)(#([a-z]+)?/?(\d+))?|/(b|s)/(\d+)).*\]((?: (?:-Easy|-NoFail|-HalfTime|\+HardRock|\+SuddenDeath|\+Perfect|\+DoubleTime|\+Nightcore|\+Hidden|\+Flashlight|~Relax~|~AutoPilot~|-SpunOut|\|Autoplay\|))*)";
string input = @"* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#osu/4133938 TUYU - Ame o Abiru]
* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#fruits/4139282 TUYU - Ame o Abiru]
* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#osu/4133938 TUYU - Ame o Abiru] +HardRock ~Relax~
* ekgame is listening to [https://osu.ppy.sh/b/4133938 TUYU - Ame o Abiru]
* ekgame is listening to [https://osu.ppy.sh/s/1989906 TUYU - Ame o Abiru]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}