import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:is listening to|is watching|is playing|is editing) \\[https?://osu.ppy.sh(/beatmapsets/(\\d+)(#([a-z]+)?/?(\\d+))?|/(b|s)/(\\d+)).*\\]((?: (?:-Easy|-NoFail|-HalfTime|\\+HardRock|\\+SuddenDeath|\\+Perfect|\\+DoubleTime|\\+Nightcore|\\+Hidden|\\+Flashlight|~Relax~|~AutoPilot~|-SpunOut|\\|Autoplay\\|))*)";
final String string = "* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#osu/4133938 TUYU - Ame o Abiru]\n"
+ "* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#fruits/4139282 TUYU - Ame o Abiru]\n"
+ "* ekgame is listening to [https://osu.ppy.sh/beatmapsets/1989906#osu/4133938 TUYU - Ame o Abiru] +HardRock ~Relax~\n"
+ "* ekgame is listening to [https://osu.ppy.sh/b/4133938 TUYU - Ame o Abiru]\n"
+ "* ekgame is listening to [https://osu.ppy.sh/s/1989906 TUYU - Ame o Abiru]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}