#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bonetwo(?:three)?|twothree\b"
Local $sString = "onetwothree" & @CRLF & _
"onetwo" & @CRLF & _
"twothree" & @CRLF & _
"" & @CRLF & _
"one" & @CRLF & _
"two" & @CRLF & _
"three"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")