package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bonetwo(?:three)?|twothree\b`)
var str = `onetwothree
onetwo
twothree
one
two
three`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}