package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://)?(?:[^/.\s]+\.)*google\.com(?:/[^/\s]+)*/?$`)
var str = `google.com
https://google.com
google.com/search
google.com.id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}