import re
regex = re.compile(r"^(?:https?://)?(?:[^/.\s]+\.)*google\.com(?:/[^/\s]+)*/?$", flags=re.MULTILINE)
test_str = ("google.com\n"
"https://google.com\n"
"google.com/search\n\n"
"google.com.id")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")