using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<MyComponent\s[^<>]*)([^\s=]+)=(?:{([^{}]*)}|""([^""]*)"")(?=[^<>]*\/>)";
string input = @"<MyComponent id={123} value={345} name=""Thomas"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}