re = /(?<=<MyComponent\s[^<>]*)([^\s=]+)=(?:{([^{}]*)}|"([^"]*)")(?=[^<>]*\/>)/m
str = '<MyComponent id={123} value={345} name="Thomas" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end