#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<event>\d+-\d+-\d+\s+\d+:\d+:\d+,\d+\s(ERROR|SEVERE).*)"
Local $sString = "2021-08-31 02:03:52,081 INFO [stdout] jkwqdwqjdk" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83) Abc fgh, app continuing" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)" & @CRLF & _
"" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)kwqskqw" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)" & @CRLF & _
"2021-08-31 02:03:52,081 INFO [org.kjskj.akjs] (ServerService Thread Pool -- 11) WFLYUT0021: Registered web context: '/dyn' for server 'default-server'" & @CRLF & _
"2021-08-31 02:03:52,081 ERROR [org.kjskj.akjs] "There is an error"" & @CRLF & _
"2021-08-31 02:03:52,081 SEVERE [org.kjskj.akjs] There is Severe" & @CRLF & _
"2021-08-31 02:03:55,166 INFO [org.jboss.as] (Controller Boot Thread) WAAAAAA0033: JBoss EAP 1.1.9.GA (abcfegc Core 2.0.10.Final-call-00000) started in 169999ms - Started 2222 of 2222 services (311 services are lazy, passive or on-demand)" & @CRLF & _
"2021-08-31 02:03:55,169 INFO [org.jboss.as] (aa nnnThread) WAAAAAA0033: Http interface listening on http://111.11.11.11:8080/aaa" & @CRLF & _
"2021-08-31 02:03:55,169 INFO [org.nnn.as] (ioio llkl Thread) WAAAAAA0033: console listening on http://111.11.11.11:8080/aaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")