import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<event>\\d+-\\d+-\\d+\\s+\\d+:\\d+:\\d+,\\d+\\s(ERROR|SEVERE).*)";
final String string = "2021-08-31 02:03:52,081 INFO [stdout] jkwqdwqjdk\n"
+ "2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)\n"
+ "2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83) Abc fgh, app continuing\n"
+ "2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)\n\n"
+ "2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)kwqskqw\n"
+ "2021-08-31 02:03:52,081 INFO [stdout] (ServerService Thread Pool -- 83)\n"
+ "2021-08-31 02:03:52,081 INFO [org.kjskj.akjs] (ServerService Thread Pool -- 11) WFLYUT0021: Registered web context: '/dyn' for server 'default-server'\n"
+ "2021-08-31 02:03:52,081 ERROR [org.kjskj.akjs] \"There is an error\"\n"
+ "2021-08-31 02:03:52,081 SEVERE [org.kjskj.akjs] There is Severe\n"
+ "2021-08-31 02:03:55,166 INFO [org.jboss.as] (Controller Boot Thread) WAAAAAA0033: JBoss EAP 1.1.9.GA (abcfegc Core 2.0.10.Final-call-00000) started in 169999ms - Started 2222 of 2222 services (311 services are lazy, passive or on-demand)\n"
+ "2021-08-31 02:03:55,169 INFO [org.jboss.as] (aa nnnThread) WAAAAAA0033: Http interface listening on http://111.11.11.11:8080/aaa\n"
+ "2021-08-31 02:03:55,169 INFO [org.nnn.as] (ioio llkl Thread) WAAAAAA0033: console listening on http://111.11.11.11:8080/aaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}