package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)EDT\s\d*\s(?<USERNAME>[^\s]+)\s*(?<STATUS>\w+( & \w+)?)\s*(?<EXPIRY>\d+-[A-Z]+-\d+)?\s*(?<ROLE>[A-Za-z0-9_-]+)`)
var str = `Thu Sep 5 10:00:02 EDT 2019 XDB EXPIRED & LOCKED 28-SEP-11 CTXAPP
Thu Sep 5 10:00:02 EDT 2019 VWEinsnte3345 LOCKED GPW_READ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}