package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<Number>[^.]+)\. (?<First>[^-]+) - (?<Second>[^(]+)(?: \((?<Third>[^)]+)\))?$`)
var str = `1. Line One - Part Two (Optional Third Part)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}